Have I Been Squatted

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Certificate transparency search engine failure
Resolved·Partial outage

The incident affecting certgrep has been resolved. Service is operating normally. A post-incident review will be conducted and a summary may be published to this page.

Fri, Jul 10, 2026, 06:19 AM
(1 week ago)
·
Affected components
Jul 8, 2026, 01:34 PM
01:36 PM
Domain Monitoring jobs
Deep Analysis jobs
API
Updates

Resolved

The incident affecting certgrep has been resolved. Service is operating normally. A post-incident review will be conducted and a summary may be published to this page.

Fri, Jul 10, 2026, 06:19 AM

Monitoring

We have implemented the necessary fixes to avoid cascading failures, and are currently resolving the underlying issue with certgrep (https://certgrep.sh/).

Wed, Jul 8, 2026, 01:36 PM(1 day earlier)

Identified

The cause of the issue affecting Have I Been Squatted has been identified. Work is in progress to implement a fix.

Wed, Jul 8, 2026, 01:34 PM